BUG - Editor eigene Seite, Bilder verlinken

17.02.2010 14:53 (zuletzt bearbeitet: 17.02.2010 14:54)
avatar  mihca02
#1 BUG - Editor eigene Seite, Bilder verlinken
mi
User

Bezieht sich auf: Erstellung eigene Seite mit dem integrierten Editor, weil es ja einfach sein soll

Benutzt wude GAIA Template (ist aber bei Standard genauso) mit IE

Es wurde eine Seite angelegt auf der Logos zu verschiedenen Treffen zu sehen sind. Diese sollten zu den verschiedenen Fotoalben verlinkt werden. (Bild 1)
Eigentlich einfach sollte man denken.

Die Fotos in der Reihe sind durch den Editor mit "Bild einfügen" angelegt worden. Der html Code des Ediotors (oben aus der Symbolbar) weist den folgenden Code dazu aus:

1
2
<div style="text-align: center;"><img style="margin-left: 10px; margin-right: 10px;" title="Hamburg 2009" src="https://files.homepagemodules.de/b200269/a_51.jpg" alt="Hamburg 2009" width="121" height="160" /><img style="margin-left: 10px; margin-right: 10px; border: 0px;" src="https://files.homepagemodules.de/b200269/a_29.jpg" alt="GPX Treffen 2009" width="154" height="160" /><img style="margin-left: 10px; margin-right: 10px; border: 0px;" src="https://files.homepagemodules.de/b200269/a_28.jpg" alt="XS Treffen 2009" width="120" height="160" /><img style="margin-left: 10px; margin-right: 10px;" title="Oldenburg 2009" src="https://files.homepagemodules.de/b200269/a_52.jpg" alt="Oldenburg 2009" width="120" height="160" /></div>



Nun markiere ich das erste Bild und lege den Link mit "Link einfügen" an

nun sieht das erste Stück aus dem Code oben so aus, was ja auch richtig ist:

1
2
<div style="text-align: center;"><a href="http://fotoalbum.xs400.net/main.php?g2_itemId=11607" target="_blank"><img style="margin-left: 10px; margin-right: 10px;" title="Hamburg 2009" src="https://files.homepagemodules.de/b200269/a_51.jpg" alt="Hamburg 2009" width="121" height="160" /></a>



Folgerichtig geht man nun hin und markiert nur das 2. Bild um diesem auch einen Link über die Funktion "Link einfügen" zu geben.

Jetzt stellt man nach abspeichern und aufrufen de rSeite fest, da ß de rlink nicht nur für das 2. Bild gesetzt wird, sondern für das 1. Bild gleich mit.

Der falsche Code sieht dann so aus:

1
2
<div style="text-align: center;"><a href="http://www.gpx750r-treffen.de" target="_blank"><img style="margin-left: 10px; margin-right: 10px;" title="Hamburg 2009" src="https://files.homepagemodules.de/b200269/a_51.jpg" alt="Hamburg 2009" width="121" height="160" /><img style="margin-left: 10px; margin-right: 10px; border: 0px;" src="https://files.homepagemodules.de/b200269/a_29.jpg" alt="GPX Treffen 2009" width="154" height="160" /></a>



Wie man sieht wurde jetzt nicht das 2. Bild verlinkt sondern die neuen Verlinkung auf das 1. Bild ausgedehnt.

Das selbe passiert bei einer Verlinkung von Bild 3, da werden die Bilder 1+2 in die Verlinkung von Bild 3 einbezogen

Das sieht dann so aus:

1
2
<div style="text-align: center;"><a href="http://fotoalbum.xs400.net/main.php?g2_itemId=14508" target="_blank"><img style="margin-left: 10px; margin-right: 10px;" title="Hamburg 2009" src="https://files.homepagemodules.de/b200269/a_51.jpg" alt="Hamburg 2009" width="121" height="160" /><img style="margin-left: 10px; margin-right: 10px; border: 0px;" src="https://files.homepagemodules.de/b200269/a_29.jpg" alt="GPX Treffen 2009" width="154" height="160" /><img style="margin-left: 10px; margin-right: 10px; border: 0px;" src="https://files.homepagemodules.de/b200269/a_28.jpg" alt="XS Treffen 2009" width="120" height="160" /></a>



und so weiter und so fort. Das kann doch nicht im Sinne des Erfinders sein, daß das nicht geht.

Klar kann ich das selber im Quellcode bearbeiten und meine Verlinkungen manuell richtig setzen. Aber dann brauche ich die Funktion des Editors nicht und für Anwender die nicht in html unterwegs sind wird es zur Hürde.

Grüße
Achim

P.S. wer jetzt den Code nicht sieht, sorry da kann ich auch nichts für, ist bei Benutzung des IE noch so

-------------------------------------------------------------------

Bildanhänge

 Antworten

 Beitrag melden
17.02.2010 15:11 (zuletzt bearbeitet: 17.02.2010 15:12)
#2 RE: BUG - Editor eigene Seite, Bilder verlinken
avatar
Administrator

Ich konnte das Verhalten im Firefox soeben nicht reproduzieren.
Zwei Bilder eingefügt, anschließend die links der Bilder gesetzt -> fehlerfreie Darstellung & fehlerfreies HTML-Code.

Sie können dieses Verhalten ggf. mit verschiedenen Optionen wie Wechsel des Browsers/andere Reihenfolge der Operationen etc. umgehen.
Wenn der Editor nicht Ihren Vorstellungen entspricht, können sie ihn zudem jederzeit deaktivieren und die Seiten direkt im HTML-Quelltext bearbeiten..

Wir haben nicht den Anspruch an den Editor eine komplexe Seitenbearbeitung (wie sie z.B. eine Software wie Dreamweaver oder Frontpage bzw. eigene HTML-Kenntnisse ermöglichen) zu ersetzen. Wenn Sie die Funktion/das Layout eigener Seiten im Detail verändern möchte, greifen Sie auf HTML zurück und/oder verwenden Sie einen HTML-Editor für ihren Computer.
In diesem Sinne danke ich für die Fehlermeldung, weise jedoch auch darauf hin, dass wir uns nicht im Detail um solche Feinheiten eines HTML-Editors kümmern können.

Mit freundlichen Grüßen,
Joh. Voß


xobor.de · Miranus GmbH · Wir helfen gerne - Unterstützen Sie Xobor durch die Buchung eines Premium Tarifs.

 Antworten

 Beitrag melden
17.02.2010 15:38
avatar  mihca02
#3 RE: BUG - Editor eigene Seite, Bilder verlinken
mi
User

Dafür das man sich mit dem Editor an den "Anwender ohne html" Kenntnisse richtet, ist das eine ziemlich komische Aussage.

Und zwei oder mehr Bilder nebeneinander zu verlinken, ist ja wohl auch nicht eine "komplexe Seitenbearbeitung" geschweige denn mit Aufgaben die z.Bsp in Macromedia gemacht werden, zu vergleichen.

Ich kann den Fehler auch 20 zig mal wiederholen, das Ergebnis bleibt dasselbe.

Ausserdem hat es nichts damit zu tun ob mir der Editor gefällt oder nicht. Wenn er da ist sollte man ihn benutzen können, gerade im Hinblick auf Anwender ohne html Kenntnisse denen man ja diese Funktion zur Verfügung stellt.

Zitat
Wenn Sie die Funktion/das Layout eigener Seiten im Detail verändern möchte, greifen Sie auf HTML zurück und/oder verwenden Sie einen HTML-Editor für ihren Computer.



Das habe ich doch gar nicht vorgehabt, ich wollte eine ganz einfache Seite erstellen, Text und Bilder und fertig ist.

Zitat

In diesem Sinne danke ich für die Fehlermeldung, weise jedoch auch darauf hin, dass wir uns nicht im Detail um solche Feinheiten eines HTML-Editors kümmern können.



Wenn der 2. Satz zutreffen sollte, frage ich mich warum man dann so etwas zur Verfügung stellt.
Und wenn unter Feinheiten die Verwendung eines Symbols aus der Menüleiste des Editors fällt bin ich fehl am Platze ...

Wenn Fehler innerhalb der Funktionen des Templates, das mir angeboten wird, auftreten ist hier der Platz um sie zu dokumentieren. Und dabei hat es nichts damit zu tun, ob ich mir selber helfen könnte oder nicht.
Und ob ihr euch darum kümmert oder nicht, liegt nicht in meinem Ermessen, die Antwort habt ihr selber gegeben



Thema durch - kann geschlossen werden

-------------------------------------------------------------------


 Antworten

 Beitrag melden
17.02.2010 16:08 (zuletzt bearbeitet: 17.02.2010 16:14)
avatar  Ingmar
#4 RE: BUG - Editor eigene Seite, Bilder verlinken
avatar
Technik

Wird geschlossen, trotzdem noch 2 Sätze dazu:


Wir hatte vor einiger Zeit überlegt, dass es schön wäre (in Bezug auf HTML) unbeholfenen Nutzern eine Möglichkeit zu bieten, HTML-Seiten zu erstellen.
TinyMCE hat zwar auch noch einige Probleme, ist aber meines Wissens der stabilste Web-HTML-Editor - daher haben wir ihn eingebaut.

Dennoch haben wir nicht den Anspruch (und auch nicht die Zeit), den Editor weiterzuentwickeln bzw. umzuschreiben.
Wenn also fehlerhafter Code produziert wird ist das zwar schade, aber wirklich nicht unser Problem bzw. Aufgabenbereich.
Im Bugreport des TinyMCE sind momentan über 1000 noch offene Fehler gelistet - und trotzdem gibt es keine bessere mir bekannte open-source Lösung.

Es bleibt also jedem selbst überlassen, ob er zur Erstellung eigener Seiten den angebotenen TinyMCE mit allen seinen Macken verwenden will oder ein eigenes Tool - für User, die wirklich keine Ahnung vom HTML-Syntax haben ist der Editor trotzdem eine Erleichterung, auch wenn nicht immer auf Anhieb das erwartete Ergebnis herauskommt. Alle, die bei der Nutzung des tinyMCE an dessen Grenzen stoßen sollten sich nach einem anderen Tool umsehen, oder etwas HTML lernen.

Gruß
Ingmar


PS: falls dir ein stabilerer online-Editor bekannt ist schaue ich mir den gerne an...

Viele Grüße,
Ingmar


 Technik · Homepagemodules.de · Miranus GmbH

 Antworten

 Beitrag melden
17.02.2010 17:18 (zuletzt bearbeitet: 17.02.2010 17:18)
avatar  mihca02
#5 RE: BUG - Editor eigene Seite, Bilder verlinken
mi
User

Hallo Ingmar,

einer solchen Argumentation kann ich ja auch folgen, danke dafür.

Ich hatte mich nur geärgert, daß solch einfache Aufgaben mit gotteiswas für anspruchsvollen HTML- Aufgaben verglichen werden und über die Art und Weise wie es abgeschmettert wird.

Das TINY MCE längst nicht fehlerfrei ist ist mir selber auch klar. Vielleicht mal eine Kompromissweg versuchen, den TinyMCE auf die Komponenten reduzieren die nachweislich problemlos gehen und auch im Template nachher korrekt umgesetzt werden (Damit würde man den Anwendern ohne html Kanntnissen gerecht) und den Benutzern mit HTML Kenntnissen oder für "anspruchsvolle Aufgaben" steht dann ja der Quellcodeeditor zur Verfügung.

Ich werde gern mal ein paar Versuche dazu anstellen, wenn gewünscht.

Grüße
Achim

-------------------------------------------------------------------


 Antworten

 Beitrag melden
Bereits Mitglied?
Jetzt anmelden!
Mitglied werden?
Jetzt registrieren!