Seite 1 von 2
#1 Erste Eindrücke Responsive Design von F. Peters 18.03.2019 23:35

avatar

Ich finde es Top , dass diese Testphase jetzt auf diversen Endgeräten durchgeführt werden kann.

Erste Rückmeldungen meinerseits:
- in Funktionen, wo die vorhandene Iconbar verfügbar ist,( Neues Thema erstellen, Antworten, Kommentar schreiben usw.), wird die Iconbar völlig "zerrissen" dargestellt
- der eingestellte Seitenhintergrund ändert sich bei "Antworten" und "Neues Thema erstellen" plötzlich auf weiß

#2 RE: Erste Eindrücke Responsive Design von F. Peters 19.03.2019 03:28

avatar

- in der Bildergalerie sind die Schalter "Bedanken&Bewerten" ohne erkennbare Funktion
- ebenso lässt sich dort die Iconbar gar nicht öffnen

P.S.: Ist es möglich, den "Umschalter" für die User als Navi-Button zu konfigurieren ?
(ich frage das, weil meine Userschaft vorwiegend wenig PC Kenntnisse besitzt und die meisten wahrscheinlich noch nie bis zu den "persönlichen Einstellungen" vorgedrungen sind )

#3 RE: Erste Eindrücke Responsive Design von Sami 25.03.2019 18:59

avatar

Zitat von F. Peters im Beitrag #1
- der eingestellte Seitenhintergrund ändert sich bei "Antworten" und "Neues Thema erstellen" plötzlich auf weiß


Konnte ich gerade nicht reproduzieren, ich vermute es könnte mit dem fehlerhaften Iconbar zutun haben - wie bereits im anderem Thema geschrieben werden wir das demnächst genauer prüfen.

#4 RE: Erste Eindrücke Responsive Design von F. Peters 25.03.2019 19:49

avatar

@Sami

Die Hintergrundfarbe ändert sich in beschriebener Weise nun nicht mehr, warum auch immer ?

Das tritt nun noch auf, wenn ich beispielweise in der Galeriebildansicht den Vollbildmodus wähle, was ich aber an anderer Stelle schon mal erwähnt hatte. Da wäre es schön , wenn man den HG der Vollbildansicht irgendwie bearbeiten könnte ?

#5 RE: Erste Eindrücke Responsive Design von F. Peters 28.03.2019 18:56

avatar

Der Rücksprung aus dem Responsive Design in die "normale" TP-Ansicht ist derzeit über location.reload(): definiert.
Das macht Probleme, wenn z.Bsp. das Portal als Startseite festgelegt ist.
Man landet also, wenn man sich im mobilen TP auf der Forenübersicht befindet und zurück in die Desktopansicht springt, auf dem Portal !
Was offenbar auch als Cookie gespeichert wird, denn der Aufruf /forum.php ist anschließend nicht mehr möglich.
Als Notlösung habe ich nun zunächst location.reload(): gegen window.location='/forum.php'; ausgetauscht, damit man nicht mehr auf dem Portal festhängt.
Das hat natürlich den Nachteil, dass man nun auch beim Rücksprung aus anderen Anwendungen in der Forenübersicht landet und somit nicht direkt die Ansichten "mobile" & ""normal" vergleichen kann.

Wie kann man denn da eine Lösung finden ?

#6 RE: Erste Eindrücke Responsive Design von Ingmar 29.03.2019 15:43

avatar

Zitat
Wie kann man denn da eine Lösung finden ?



Man könnte die aktuelle Siete abfragen und entsprechend weiterleiten:

1
2
3
4
5
 
if(window.location.pathname === "/"){
window.location='/forum.php';
}else{
location.reload():
}
 

#7 RE: Erste Eindrücke Responsive Design von F. Peters 29.03.2019 18:45

avatar

Ingmar, ich stelle mich zu blöd an.

Ich weiß nicht, was ich da bei pathname reinschreiben soll. Nehme ich die Adresse der Forenübersicht mobile funktioniert es nicht.
So oder so wird nur reload augeführt und ich lande beim Rücksprung aus Forenübersicht (mobile) auf dem Portal (Business TP).
Was mache ich falsch ?

1
2
3
4
5
6
7
8
9
 
function My_mb_out(){
xobor.cookie.del('testmobile');
if(window.location.pathname === "/"){
window.location='/forum.php';
}
else{
location.reload();
}
}
 



(den kleinen Test mit dem Doppelpunkt habe ich zumindest bestanden. )

#8 RE: Erste Eindrücke Responsive Design von Ingmar 29.03.2019 20:19

avatar

Zitat von F. Peters im Beitrag #7
(den kleinen Test mit dem Doppelpunkt habe ich zumindest bestanden. )


Sehr gut aufgepasst - das gibt Fleißpunkte ;-)

Zitat
Ich weiß nicht, was ich da bei pathname reinschreiben soll.


Hm, eigentlich sollte "/" für die Foren-Übersicht schon passen.

Du kannst das aber auch einfach selbst testen.

Mit F12 die Konsole öffnen, dort window.location.pathname eintippen und enter drücken - dann erscheint der gesuchte Wert in der Konsole.

#9 RE: Erste Eindrücke Responsive Design von F. Peters 29.03.2019 21:05

avatar

...das habe ich schon gemacht und es wird genau der Pfad angegeben. Trotzdem erfolgt der Rücksprung ins Portal
und nicht auf die /forum.php ...

#10 RE: Erste Eindrücke Responsive Design von F. Peters 30.03.2019 12:00

avatar

Ingmar, kannst Du hier bitte noch mal gucken bei Gelegenheit ?

Meine User sollten eigentlich alle mal testen, aber sie sind nun etwas verunsichert, weil sie beim Rücksprung aus der responsiven Ansicht (Forumübersicht) immer im Portal landen ... und dann der Aufruf /forum.php erst wieder nach Leeren des Cache möglich ist.

#11 RE: Erste Eindrücke Responsive Design von Ingmar 01.04.2019 16:50

avatar

Das Script von oben funktioniert einwandfrei - nur dank des Caching-Fehlers bei der Weiterleitung landet man eben dann trotzdem im Portal.

Ich denke ich habe das Problem nun intern behoben, indem ich das Caching an dieser Stelle unterbinde.

~intern behoben~
Änderungen werden immer erst mit dem nächsten Update übernommen. Der Zeitpunkt und Umfang des Updates werden unter Aktuelle News bekanntgegeben

#12 RE: Erste Eindrücke Responsive Design von F. Peters 10.04.2019 04:12

avatar

Das Script funktioniert soweit, keine Frage. Dennoch führt der Rücksprung nach wie vor ins Portal, (ohne Aufrufmöglichkeit der ...forum.php. wenn man nicht den Cache geleert hat.), was viele meiner User verunsichert und vom Test des responsive Designs abhält. Schade eigentlich.

Auch wenn sich hier ansonsten niemand zu dieser Problematik meldet, bin ich sicher nicht der Einzige, der das Portal als Sterstseite verwendet ?

#13 RE: Erste Eindrücke Responsive Design von Ingmar 10.04.2019 10:01

avatar

Zitat
Ich denke ich habe das Problem nun intern behoben



Zitat von Ingmar im Beitrag #11
Änderungen werden immer erst mit dem nächsten Update übernommen


#14 RE: Erste Eindrücke Responsive Design von F. Peters 10.04.2019 13:31

avatar

Oh, sorry, dann hab ich das falsch verstanden. Ich dachte , es gäbe eine dazu eine neue Pluginversion.

Dann warte ich halt auf das nächste Update.

#15 RE: Erste Eindrücke Responsive Design von Ingmar 10.04.2019 14:19

avatar

Zitat von F. Peters im Beitrag #14
Oh, sorry, dann hab ich das falsch verstanden. Ich dachte , es gäbe eine dazu eine neue Pluginversion.


Nein, das Problem hat ja mit dem Plugin bzw dem mobilen Template nichts zu tun. Der Fehler entsteht im Firefox z.B. auch, wenn du z.B. für Gäste das Portal als Startseite nimmst und für Mitglieder nicht und dann einmal als Gast beide Seiten (Portal/Forum Übersicht) aufrufst.